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Summary: 

This document contains some tutorials for the tools used mainly during lecture exercises. They are 

aimed at getting used to the software environments, gathering tips and tricks, and locating the 

available resources. 

The examples are not analysed in details, and might not be meaningful for real-life usage, but focus 

on getting a simple task done from A to Z, while covering most of the required functionalities of the 

software environments. 
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1 Analog Design 
 

The analogic circuit design, simulation and layout interface is called “Virtuoso IC”. This section will 

present   

For now, the Analogic Design tutorials will be realised using the UMC 65nm design kit, which is the 

only one installed 

 

1.1 Load the Design Kit 
 

To load the design tools, you just need to load a design kit, which will in Turn load the appropriate 

software chain. The design kit contains that basic component definitions available in the target 

technology, like transistors, capacitors etc… 

At the command prompt, just source the design kit load script: 

 

$ source /opt/adl_cadence/umc_65.sh 

 

 

 

1.2 Work folder preparation 
 

Create a folder dedicated to working with the chosen design kit. Typically, it should be created for a 

specific project, or set of library components.  

For the exercices, one folder is enough: 

$ mkdir das-exercices-umc65 

$ cd das-exercices-umc65 

 

1.3 Start Virtuoso 
 

Just type “virtuoso” at the command prompt: 

$ virtuoso 

The source command loads a script as if you had typed the command one by one. If you just run the script 

by typing /opt/ adl_cadence /umc_65.sh, a process will be created and destroyed at the end of execution, 

which prevents the modification of the terminal’s environment variables, which is necessary for a proper 

tool loading. 
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When starting virtuoso from a location in the file system, it will look for a local “cds.lib” file. This file 

contains references to other locations on the file system, where some component libraries may be 

found. It can be edited from Virtuoso by the Library Manager. 

By default, the cds.lib file gets populated at least with the location of the design kit technology 

library provided by the factory, where you can find the base transistor components for example.  

The initial GUI is very light, you should only see the console window, which reports various 

informational and error messages: 

 

 

1.4 The Library manager 
 

The various circuits are structured as following: 

 Library: A library contains some Cells 

o Cells: A Cell represents a circuit, and contain the various views of the cell 

 Views: The views are the various possible descriptions for a cell. For 

example, a schematic view will be the formal circuit description, while the 

layout view will be the physical drawing. 

The Library Manager in Virtuoso mirrors this organisation. To open it, Click “Tools -> Library 

Manager”: 
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Now we can have a look at the views available for a transistor cell of the design kit library “umc65ll” : 

 

To edit the view of a cell, just click on the view name and the appropriate editor will start. 

 

  

cds.lib 

Design Kit 

Library 

Transistor cell 

Symbol Physical 

Layout 
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1.5 Simple ideal schematic Design 
 

The schematic entry is the first stage of a circuit design.  Using the schematic editor, you will: 

 Place, configure and connect the circuit components 

 Place, configure and connect simulation components, like voltage sources and signal 

generators 

 Launch Simulations 

The components you can use on you circuit will be available from three main sources: 

 The Technology Library, specific from the target technology. 

 The standard ideal components (Signal sources etc…) from the “analogLib” library. 

 The additional libraries you add to you library manager, which may contain shared and third-

party components designed for your target technology, or for simulation purpose. 

 

 

To get used to the Virtuoso environment, we are going to start with a simple RC pass filter circuit, 

only requiring ideal components: 
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1.5.1 Cell + Schematic Creation 
 

 Create a “Tutorial” Library 

o Open The Library Manager, File -> New -> Library 

o Save the Library in the current Folder 

 
o Attach the library to the design kit technology file 

 
 

 Create an “example1” cell, with a schematic view: File -> New Cell View… 
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 A schematic editor window should open: 

 

 

Our RC circuit is very simple and only requires ideal components taken from the “analogLib” library, 

which you can explore from the library manager. 

  

Schematic Area 
Components Tree 
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1.5.2 Component instantiation 
 

To add a component to the circuit:  

 Press the I (Instance) key 

 Enter the source library: analogLib 

 Enter the component name 

 Select the view type: Symbol  

 (optional) You can add some names 

for the schematic. 

 

 

 

If the selection matches a component, two things happen: 

 The Add Instance window expands to show the component’s properties. You can edit them 

right away or later. 

 You should be able to add the component to the schematic without closing the Add Instance 

window. Just move the mouse over the schematic area. 

For our circuit, we will need: 

 A resistor “res” 

 A capacitor “cap” 

 A Signal generator “vpulse” 

 A Ground component “gnd” 

Add those components to the schematic, this is how it looks like for the resistor: 

 

Component Name 

Instance Name 
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1.5.3 Wiring 
 

Once you have added all the components, press the W key to enter wiring mode, and connect the 

components with each other: 

 

Schematic Editor Tips: 

- Press Escape (multiple times) to quit the current add-edit mode and return to the normal 

select mode 

- To Rotate a component, go back to select mode, select it, press R  

- See the Schematic Editor Cheat sheet for a quick reference 
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1.5.4 Edit the properties 
 

Now we can edit the properties of the components in 

our circuit. To do so, select a component, and press Q to 

access the edit properties window: 

 Set the vpulse AC parameters: 

o AC Magnitude = 1V 

o AC phase = 0 

 Set the resistor value: 2K  

 Set the capacitor value: 100n 

For a simple first-order pass-filter, the cut-off frequency 

is =
1

2𝜋𝑅𝐶
 , in our case then around 795Hz. We will try to 

check this in the simulation. 

 

 

 

 

1.5.5 Check and save the circuit 
 

After any change to the circuit, click on the check and save button to verify the circuit’s basic 

connectivity, and generate the correct netlist. If an error occurs, a message window will pop-up, and 

a log output will be written to the console window. 
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1.5.6 Run a simulation 
 

Now we are ready to run a Simulation. Click on Launch -> ADE L to open the simulation environment: 

 

Let’s setup the simulation: 

 First select an analysis type by clicking the Analyses selection 

button: 

o  The Analysis window allows configuring all the enabled 

analysis.  

o We want to perform a Frequency response analysis. 

o Select the “ac” anaylis 

o Set Sweep Variable to Frequency 

o Set the Start and Stop values of the sweep range to 1 – 

1G (1hz to 1Ghz) 

 Then, select to output to be plotted by clicking the output 

selection button: 

o You can select the output by entering node names per 

hand 

o Otherwise, click on the “From Design”  button, and 

click on the schematic to add a node or wire to the 

outputs. 

o When finished adding the outputs, press Esc on the 

schematic and close the dialog box. 

o Add the Wire between the resistor and capacitor as output: 

 

Analyses 

Selection 

Plot Output 

Selection 
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Now the simulation window is ready, we can run the simulation by clicking the play button: 
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The output plot should appear automatically, and show the output voltage based on the frequency. 

However, for that kind of analysis, we want to see the Bode Plot showing the attenuation and phase 

shift, so that we can check our cut-off frequency. 

To do so, go back to the main simulation window: 

 Select Results -> Direct Plot -> AC Magnitude an Phase 

 The schematic window will come in front 

 

 Select the output wire, as for the output selection 

 Press Esc 

 The Plot window should come back with the Magnitude in db and Phase shift traces. 

 You can use the split traces button to display the traces separately 

 

 

Phase Shift 

Attenuation 

Split traces 
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The cut-off frequency is defined for an attenuation of 3db (half of the input). You can use the mouse 

to search for the point. 
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1.5.7 Save and restore simulation state 
 

Now that we have performed our simulation, we can save its configuration (aka state) and reload it 

later. To do so, go back to the simulation window: 

 To save, click on Session -> Save State… 

o On the dialog, set Save State Option: CellView (the state will be saved as a view of 

the cell) 

o Under CellView Options, you can change the name of the state 

o You can use a different save mode if you like, but this one is quite convenient. 

 To restore, click on Session -> Load State… 

o The dialog box the same as the save one, just set the same values. 

 

 

  



16 
 

1.6 Complete Physical Circuit with Layout Editor 
 

Now that we have completed a simple simulation for an ideal circuit, we are going to see how to 

implement a  CMOS inverter UMC65nm.  

 

 

 

Questions: 

 Schematic: 

o Why do we need pins for bulk contact, (not directly connected) 

 AW: Keep the option to connect to different voltage source 

o Simulation: 

 Simulate on same schematic? 

 create a new view with the symbol? 

 Symbol: 

o Import definitions from schematic -> Schematic -> Edit -> create Cellview from 

cellview 

o Edit -> Origin 

o Selection box 

o Move around stuff 

 Testbench 

o Create Labels 

 

1.6.1 Schematic 
 

1.6.2 Symbol  
 

1.6.3 Testbench 
 

1.6.4 Physical Layout 
 

 Pins not necessary 

 Wires connect to correct anme 

 Add vias for input 

o Maybe not depending on usage 

 Add via for nwell-psub 
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1.6.5 DRC 
 

1.6.6 LVS 
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1.7 Virtuoso Cheat Sheet 
 

1.7.1 Schematic Editor 
 

Keyboard Command Description 

All modes 

 

Quit mode (Back to select)  

Select Mode 

 

Add a component  

 

Enter wiring mode  

 

Add a Name Label  

 

Move an object First Click the object to move, then drag. 
Direct dragging will usually drag the 
previously selected object. 

 

Add a Pin  

 

Fit Zoom to fit the whole schematic in the 
window 

 

Enter Delete Mode Click anything to delete it 

Selected Mode 

 

Edit Properties  

 

Rotate  
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1.7.2 Simulation Browser (ADE) 
 

Keyboard Command Description 

 

Add a Marker on the curve Move the along the curve, and press M to 
place a marker at mouse position 

 

Add a vertical marker on the graph Move the along the curve, and press V to 
place a marker at mouse position 

 

1.7.2.1 Delta Marker 

 

To create a delta (difference) marker between two vertical markers: 

 Place your vertical markers 

 Select them with clicking them while holding control 

 Press Shift + D 
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1.7.3 Layout Editor 
 

Keyboard Command Description 

All modes 

 

Quit mode (Back to select)  

Select Mode 

 

Add a component  

 

Label Shape  

 

Move an object First Click the object to move, then drag. 
Direct dragging will usually drag the 
previously selected object. 

 

Create a Via  

 

Wire Shape  

 

Rectangle Shape  

 

Shape/Reshape Got to select mode, activate reshape mode, 
then click on the side handles of the object to 
reshape once, and move the mouse to 
reshape (don’t drag the mouse…) 

 

Fit Zoom to fit the whole schematic in the 
window 

 

Enter Delete Mode Click anything to delete it 

Selected Mode 

 

Rotate  

 

Edit Properties  

   

   

 


